読者です 読者をやめる 読者になる 読者になる

PGメモ

非エンジニアの記録

Ruby&Ruby on Railsインストール on Linux

centOSなのでyumでさくさく入れます。と言いたいところですが、1.8.7以降は入らないのでソースから入れます

wget http://cache.ruby-lang.org/pub/ruby/2.0/ruby-2.0.0-p247.tar.gz
tar xfvz ruby-2.0.0-p247.tar.gz
cd ruby-2.0.0-p247
./configure -prefix=/usr
make
make install
# ruby -v
ruby 2.0.0p247 (2013-06-27 revision 41674) [i686-linux]

次にgemを入れます
http://rubyforge.org/frs/?group_id=126
からお好きなものを。

# wget http://rubyforge.org/frs/download.php/76729/rubygems-1.8.25.tgz
# tar zxvf rubygems-1.8.25.tgz
# cd rubygems-1.8.25
# ruby setup.rb

railsをインストール

gem install rails
 Unable to resolve dependencies: sprockets requires hike (~> 1.2), tilt (!= 1.3.0, ~> 1.1); mail requires mime-types (~> 1.16), treetop (~> 1.4.8)

と出たのでgemコマンドで次々インストール

再度railsのインストールにトライ。無事インストールされた。